OSX 10.11 El Capitan

Its that time of the year again, today (9/30/2015) apple has released a new OS verison for apple computers . Version 10.11 code named El Capitan Build 15A284. You can download and install this version of OSX from the app store on your apple computer.

OS X El Capitan system requirements

If your Mac was able to run Mavericks or Yosemite it will be able to run El Capitan. Those supported Macs include:

  • iMac (Mid 2007 or newer)

  • MacBook Air (Late 2008 or newer)

  • MacBook (Late 2008 Aluminum, or Early 2009 or newer)

  • Mac mini (Early 2009 or newer)

  • MacBook Pro (Mid/Late 2007 or newer)

  • Mac Pro (Early 2008 or newer)

  • Xserve (Early 2009)

All of those Macs feature a 64-bit CPU. You’ll also need about 6GB of space to be available for the install (so make sure you have more room than that or you may encounter issues).

Find out if your Mac is supported by clicking on the Apple logo in the top left of your screen, and selecting About this Mac > Overview. There you will see details of which Mac you have, and the year that model first appeared.

When Apple announced that El Capitan would have the same system requirements as Yosemite and Mavericks it confirmed that the next version of OS X would actually offer improved performance on the older hardware.

Find out more here: OSX El CapitanWikiPedia